Poj3061Subsequence

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3

题意:问最少要几个连续的数字大于给定的s;
题解: 尺取法:

这是他的执行过程。
执行过程
先找到一个大于s的序列,然后对这个序列处理,直到小于s,然后在加入后面的数字,不断的循环。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[100000+10];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        long long sum=0;
        int st=0,en=0;
        int ans=0x3f3f3f3f;
        while(1)
        {
            while(en<n&&sum<m)
             sum+=a[en++];
            if(sum<m)
             break;
            ans=min(ans,en-st);
            sum-=a[st++];
        }
        if(ans==0x3f3f3f3f) ans=0;
        printf("%d\n",ans);
    }

    return 0;
 } 

猜你喜欢

转载自blog.csdn.net/qq_39576425/article/details/78287994