数论 lightoj--1336

Sigma function is an interesting function in Number Theory. It is denoted by the Greek letter Sigma (σ). This function actually denotes the sum of all divisors of a number. For example σ(24) = 1+2+3+4+6+8+12+24=60. Sigma of small numbers is easy to find but for large numbers it is very difficult to find in a straight forward way. But mathematicians have discovered a formula to find sigma. If the prime power decomposition of an integer is

Then we can write,

For some n the value of σ(n) is odd and for others it is even. Given a value n, you will have to find how many integers from 1 to n have even value of σ.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1012).

Output

For each case, print the case number and the result.

Sample Input

4

3

10

100

1000

Sample Output

Case 1: 1

Case 2: 5

Case 3: 83

Case 4: 947

题目链接:http://lightoj.com/login_main.php?url=volume_showproblem.php?problem=1336

题意:f(n)为n所有约数的和,给你一个数n,让你求从1到 n 中 由多少个f(x)的值为偶数。

将公式化简成 f(n)  = (1+p1+p1^2+p1^3+...+p1^a1)*(1+p2+p2^2+...+p2^a2)*...*(1+pn+pn^2+...+pn^an)。

偶数*偶数==偶数,奇数*奇数 == 奇数,奇数*偶数 == 偶数 奇数or偶数+1 = 偶数or奇数
由此可以看出奇数项会比较少,所以说答案  =  n - 奇数项即可。

因为素数里面除了2就都是奇数,因此上式中第一项一定是奇数,要使其他的项是奇数(当且仅当ai = 偶数)。因此满足奇数项的就是 sqrt(n)+sqrt(n/2)

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
    
typedef long long ll;
int main()
{
    int t;
    cin >> t;
    int cas = 1;
    while(t --)
    {
        ll n, sum;
        cin >> n;
        sum = n;
        sum -= (int)sqrt(n);
        sum -= (int)sqrt(n/2);
        printf("Case %d: %lld\n", cas++, sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38295645/article/details/81285557