lightoj1213数论快速幂计算贡献

If you think codes, eat codes then sometimes you may get stressed. In your dreams you may see huge codes, as I have seen once. Here is the code I saw in my dream.

#include <stdio.h>

int cases, caseno;
int n, K, MOD;
int A[1001];

int main() {
    scanf("%d", &cases);
    while( cases-- ) {
        scanf("%d %d %d", &n, &K, &MOD);

        int i, i1, i2, i3, ... , iK;

        for( i = 0; i < n; i++ ) scanf("%d", &A[i]);

        int res = 0;
        for( i1 = 0; i1 < n; i1++ ) {
            for( i2 = 0; i2 < n; i2++ ) {
                for( i3 = 0; i3 < n; i3++ ) {
                    ...
                    
for( iK = 0; iK < n; iK++ ) {
                        res = ( res + A[i1] + A[i2] + ... + A[iK] ) % MOD;
                    }
                    ...
                
}
            }
        }
        printf("Case %d: %d\n", ++caseno, res);
    }
    return 0;
}

Actually the code was about: 'You are given three integers nKMOD and n integers: A0, A1, A2 ... An-1, you have to write K nested loops and calculate the summation of all Ai where i is the value of any nested loop variable.'

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with three integers: n (1 ≤ n ≤ 1000), K (1 ≤ K < 231), MOD (1 ≤ MOD ≤ 35000). The next line contains n non-negative integers denoting A0, A1, A2 ... An-1. Each of these integers will be fit into a 32 bit signed integer.

Output

For each case, print the case number and result of the code.

Sample Input

2

3 1 35000

扫描二维码关注公众号,回复: 6113701 查看本文章

1 2 3

2 3 35000

1 2

Sample Output

Case 1: 6

Case 2: 36

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
#define maxn 10005
using namespace std;
ll a[maxn];
int t;
ll n,k,mod;
ll multi(ll a,ll b,ll m)
{
    ll ans=0;
    a%=m;
    while(b)
    {
        if(b&1)
        {ans=(ans+a)%m;
        b--;
        }
            b>>=1;
            a=(a+a)%m;
    }
    return ans;
}
ll quickpow(ll a,ll b,ll m)
{
    ll ans=1;
    a%=m;
    while(b)
    {
        if(b&1)
        {
            ans=multi(ans,a,m);
            b--;
        }
        b>>=1;
        a=multi(a,a,m);

    }
    return ans;
}


int main()
{
    scanf("%d",&t);
    int w=0;
    while(t--)
    {w++;
        scanf("%lld%lld%lld",&n,&k,&mod);
    ll sum=0;
    for(int i=1;i<=n;i++)
        {scanf("%lld",&a[i]);
        sum+=a[i];


}
ll ans=quickpow(n,k-1,mod);
ans=multi(k,ans,mod);
ans=multi(ans,sum,mod);
printf("Case %d: %lld\n",w,ans);
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/89810762