SDUT OJ 树结构练习——排序二叉树的中序遍历

树结构练习——排序二叉树的中序遍历

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

在树结构中,有一种特殊的二叉树叫做排序二叉树,直观的理解就是——(1).每个节点中包含有一个关键值 (2).任意一个节点的左子树(如果存在的话)的关键值小于该节点的关键值 (3).任意一个节点的右子树(如果存在的话)的关键值大于该节点的关键值。现给定一组数据,请你对这组数据按给定顺序建立一棵排序二叉树,并输出其中序遍历的结果。

Input

输入包含多组数据,每组数据格式如下。

第一行包含一个整数n,为关键值的个数,关键值用整数表示。(n<=1000)

第二行包含n个整数,保证每个整数在int范围之内。

Output

为给定的数据建立排序二叉树,并输出其中序遍历结果,每个输出占一行。

扫描二维码关注公众号,回复: 2395657 查看本文章

Sample Input

1
2
2
1 20

Sample Output

2
1 20

Hint

Source

赵利强

#include <stdio.h>
#include <stdlib.h>
#include<string.h>
typedef struct st
{
    int data;
    struct st *l,*r;
} tree;
int k;
tree *BST(tree *t,int key)
{
    if(t==NULL)
    {
        t=(tree *)malloc(sizeof(tree));
        t->data=key;
        t->l=NULL;
        t->r=NULL;
    }
    else
    {
        if(t->data>key)
        {
            t->l=BST(t->l,key);
        }
        else
            t->r=BST(t->r,key);
    }
    return t;
}
tree *creat(tree *t,int a[],int n)
{
    int i;
    t=NULL;
    for(i=0; i<n; i++)
    {
        t=BST(t,a[i]);
    }
    return t;
}
void zh(tree *t)
{
    if(t)
    {
        zh(t->l);
        k++;
        if(k==1)printf("%d",t->data);
        else printf(" %d",t->data);
        zh(t->r);

    }
}
int main()
{
    int n,a[1556],i;
    tree *T;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0; i<n; i++)
            scanf("%d",&a[i]);
        T=creat(T,a,n);
        k=0;
        zh(T);
        printf("\n");


    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81203389