SDUT OJ数据结构实验之求二叉树后序遍历和层次遍历

数据结构实验之求二叉树后序遍历和层次遍历

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

 已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历和层序遍历。

Input

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

Output

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列。

Sample Input

2
abdegcf
dbgeafc
xnliu
lnixu

Sample Output

dgebfca
abcdefg
linux
xnuli

Hint

Source

ma6174

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
typedef struct st
{
    char data;
    struct st *l,*r;
} tree;
tree *creat(char *tr1,char *tr2,int len)
{
    tree *p;
    if(len<=0)
        p=NULL;
    else
    {
        p=(tree*)malloc(sizeof(tree));
        p->data=*tr1;
        char *a;
        for(a=tr2; a!=NULL; a++)
            if(*a==*tr1)
                break;
        int lm=a-tr2;
        p->l=creat(tr1+1,tr2,lm);
        p->r=creat(tr1+lm+1,a+1,len-1-lm);
    }
    return p;
}
void hou(tree *t)
{
    if(t)
    {
        hou(t->l);
        hou(t->r);
        printf("%c",t->data);
    }
}

void cen(tree *t)
{
    tree *p[1250];
    int rear=0,front=0;
    if(t)
        p[rear++]=t;
    while(rear>front)
    {
        t=p[front++];
        printf("%c",t->data);
        if(t->l) p[rear++]=t->l;
        if(t->r) p[rear++]=t->r;
    }
}

int main()
{
    int t;
    tree *T;
    scanf("%d",&t);
    while(t--)
    {
        char tr1[55],tr2[55];
        scanf("%s",tr1);
        scanf("%s",tr2);
        int len;
        len=strlen(tr1);
        T=creat(tr1,tr2,len);
        hou(T);
        printf("\n");
        cen(T);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81197593
今日推荐