SDUT OJ数据结构实验之查找一:二叉排序树

数据结构实验之查找一:二叉排序树

Time Limit: 400 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

Input

输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

Output

对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出"Yes",否则输出"No"。

Sample Input

4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0

Sample Output

Yes
No
No

Hint

 

Source

xam

#include <iostream>
#include<string.h>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
typedef struct st
{
    int data;
    struct st *l,*r;
} tree;
int n,m;
int flas;
tree *creat(int x,tree  *root)
{
    if(!root)//若为空则放在头一个节点
    {
        root=new tree;//注意:这用的是tree,
        root->data=x;
        root->l=root->r=NULL;
    }
    else
    {
        if(x<root->data)//左小右大
        {
            root->l=creat(x,root->l);

        }
        else root->r=creat(x,root->r);
    }
    return root;

}
void judge(tree*root,tree*root1)
{
    if(root&&root1)//这里用的是if不是while
    {
        if(root->data!=root1->data)
        {
            flas=1;
            return;
        }
        judge(root->l,root1->l);//相同则往左递归
        judge(root->r,root1->r);//相同则往右递归,调用头函数
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)break;
        cin>>m;
        tree *root;
        root=new tree;
        root=NULL;
        int x,i;
        for(i=0; i<n; i++)
        {
            cin>>x;
            root=creat(x,root);
        }
        while(m--)
        {
            tree *root1;
            root1=new tree;
            root1=NULL;
            for(i=0; i<n; i++)
            {
                cin>>x;
                root1=creat(x,root1);

            }
            flas=0;
            judge(root,root1);
            if(flas)printf("No\n");
            else printf("Yes\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81318652