SDUT OJ 数据结构实验之二叉树二:遍历二叉树

数据结构实验之二叉树二:遍历二叉树

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。

Sample Input

abc,,de,g,,f,,,

Sample Output

cbegdfa
cgefdba

#include <stdio.h>
#include <stdlib.h>

struct node
{
    char c;
    struct node *lt, *rt;
};

char s[100];
int flag;


struct node *creat()
{
    struct node *root;
    if(s[flag]==',') {
            root=NULL;
            flag++;
    }
    else{
        root=(struct node *)malloc(sizeof(struct node));
        root->c=s[flag++];
        root->lt=creat();
        root->rt=creat();
    }
    return root;
}

void mid(struct node *root)
{
    if(root){
        mid(root->lt);
        printf("%c",root->c);
        mid(root->rt);
    }

}



void last(struct node *root)
{
    if(root){
        last(root->lt);
        last(root->rt);
        printf("%c",root->c);
    }

}


int main()
{
    while(~scanf("%s",s)){
        flag=0;
        struct node *root;
        root=creat();
        mid(root);
        printf("\n");
        last(root);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/winner647520/article/details/80410693