poj3041(最小顶点覆盖数,二分图匹配)

Strategic Game

                Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

               Total Submission(s): 5313    Accepted Submission(s): 2452


 

Problem Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree: 

 

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

Sample Input

 

4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)

Sample Output

 

1 2

Source

Southeastern Europe 2000

求最少需要几枪可以击碎所以小行星->求该图的最小顶点覆盖数

由König定理定理可知,二分图的最小顶点覆盖数等于二分图的最大匹配数

所以直接用匈牙利算法求该二分图的最大匹配数即可!

ac:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M = 1000 + 5;
int n, m;
int link[M];
bool MAP[M][M];
bool cover[M];
int ans;

bool dfs(int x)
{
    for(int y=1; y<=n; y++)
    {
        if(MAP[x][y] && !cover[y])
        {
            cover[y]=true;
            if(link[y]==-1 || dfs(link[y]))
            {
                link[y]=x;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    while(scanf("%d%d", &n, &m)!=EOF)
    {
        int x,y;
        memset(MAP, false, sizeof(MAP));
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&x,&y);
            MAP[x][y]=1;
        }
        ans=0;
        memset(link, -1, sizeof(link));
        for(int i=1; i<=n; i++)
        {
            memset(cover, false, sizeof(cover));
            if( dfs(i) )
                ans++;
        }
        printf("%d\n", ans);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41183791/article/details/81167579