Asteroids poj3041 (二分图最大匹配 / 二分图中最小点覆盖问题)

版权声明:有错误还请斧正,感激不尽。 https://blog.csdn.net/Gentle_Guan/article/details/54928914

Asteroids
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 21522   Accepted: 11697

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).



#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>

using namespace std;

#define For(i,a,b) for(i=a;i<=b;i++)
#define Out(x) cout<<x<<endl

#define ll long long
const ll inf = 1000;

bool Map[inf][inf];
bool vis[inf];
int match[inf];
int n;

bool Dfs(int key)
{
    int i;
    For(i,1,n)
    {
        if(Map[i][key] && vis[i] == 0)
        {
            vis[i] = 1;  ///如果这点没搜过
            if(match[i] == -1 || Dfs(match[i]))   ///没匹配+1 匹配有增广路也+1
            {
                match[i] = key; ///取反?
                return 1;
            }
        }
    }
    return 0;
}

int MaxMatch()
{
    int i,num;
    num=0;
    For(i,1,n)
    {
        memset(vis,0,sizeof(vis));
        if(Dfs(i))  ///有增广路 +1
        {
            num++;
        }
    }
    return num;
}

int main()
{
    int i,k,x,y;
    while (cin>>n>>k)
    {
        memset(Map,0,sizeof(Map));
        memset(match,-1,sizeof(match));
        For(i,1,k) cin>>x>>y,Map[x][y] = 1;
        ///建图很关键
        ///
        Out(MaxMatch());
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/Gentle_Guan/article/details/54928914