POJ 3041(最小点覆盖 = 二分图最大匹配)

Asteroids

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 26026   Accepted: 14075

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X. 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

题意:一个NxN的矩阵中,给定k个行星的x,y位置。主人公的武器发射一次可以 摧毁整行或者整列的 行星,问最少需要发射多少次,能够摧毁所有行星。

思路:将 x 集合,y 集合分别作为二分图的左右集合。一个点就代表其 x 与 y 相连。最后也就是要破坏所有的边,应该选哪几个点。即 最小点覆盖。而最小点覆盖 = 最大匹配数

AC代码:

#include<cstdio>
#include<queue>
#include<stack>
#include<vector>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;

const int maxn = 550;

int mp[maxn][maxn];
int vis[maxn];
int link[maxn];
int n,k;

bool dfs(int s){
    for(int i = 1;i <= n;i ++){
        if(!vis[i] && mp[s][i]){
            vis[i] = 1;
            if(!link[i] || dfs(link[i])){
                link[i] = s;
                return 1;
            }
        }
    }
    return 0;
}

int hungry(){
    memset(link,0,sizeof(link));
    int ans = 0;
    for(int i = 1;i <= n;i ++){
        memset(vis,0,sizeof(vis));
        ans += dfs(i);
    }
    return ans;
}

int main()
{
    while(~scanf("%d%d",&n,&k)){
        memset(mp,0,sizeof(mp));
        int x,y;
        for(int i = 1;i <= k;i ++){
            scanf("%d%d",&x,&y);
            mp[x][y] = 1;
        }
        int ans = 0;
        ans = hungry();
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/no_O_ac/article/details/81408669