【SSL 1341&POJ 3041】Asteroids【二分图の最小顶点覆盖】

Asteroids

Time Limit:1000MS Memory Limit:65536K

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2…K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where “X” is an asteroid and “.” is empty space:

X.X 
.X. 
.X. 

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
题目在意如下:
题目给出一个矩阵,上面有敌人,每个子弹可以打出一横行或者一竖行,问最少用多少子弹消灭都有敌人,如:

X.X 
.X. 
.X. 

x表示敌人,显然用两个子弹就可以解决所有敌人。

分析:

这道题要求的是最小顶点覆盖问题 但其实二分图最小顶点覆盖问题也就是最大匹配
把问题转换成最大匹配后 你会发现这道题和人员匹配一模一样……

另:POJ上这道题要用快读…以及简便写法邻接表POJ无法识别…

CODE:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n,s,ans,tot,x,y,head[105],vis[105],link[106];
struct node{
    
    
	int to,next;
}a[10006];
void add(int x,int y)
{
    
    
	a[++tot].to=y;
	a[tot].next=head[x];  //POJ可识别邻接表
	head[x]=tot;
}
bool find(int x){
    
    
	for(int i=head[x];i;i=a[i].next)
	{
    
    
		int p=a[i].to;
		if(!vis[p])
		{
    
    
			int qwq=link[p];
			link[p]=x;
			vis[p]=1;
			if(!qwq||find(qwq)) return true;  //模板
			link[p]=qwq;
		}
	}
	return false;
}
int main(){
    
    
	scanf("%d%d",&n,&s);
	for(int i=1;i<=s;i++)
	{
    
    
		scanf("%d%d",&x,&y);
		add(x,y);  //建立边
	}
	for(int i=1;i<=n;i++)
	{
    
    
		memset(vis,0,sizeof(vis));
		ans+=find(i);
	}
	printf("%d",ans);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/dgssl_xhy/article/details/108149750