POJ3041--Asteroids(二分图,最小覆盖点)

Description
Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.


Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.


Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.


Sample Input

3 4
1 1
1 3
2 2
3 2


Sample Output

2


Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

解题思路:给N和M,N代表N*N的矩阵,M代表接下来有M个格子,每个格子上有一个小行星,

他的武器每次可以去掉某一行或者某一列的所有小行星,然后问最少使用 多少次该武器
最小点覆盖:就是对于一个图,选取最少数量的点S,使得对于所有的边,都至少有一端点是S中的点
König定理:二分图中的最小覆盖点数==最大匹配数
这个题建图,每行对应为左边的每个点,每列对应为右边的点,然后如果(i,j)有小行星,就连一条边
然后使用最少的武器就是,选取最少的点,使得所有边都至少有一端是被选取的
所以就是二分图最小点覆盖,就是最大匹配数。

#include<stdio.h>
#include<cstring>
#include<algorithm>
using namespace std;
int f[510];
bool fr[510][510];
bool vis[510];
int n,m;
bool find(int x)
{
	for(int i=1;i<=n;i++)
	{
		if(fr[x][i] && !vis[i])
		{
			vis[i]=true;
			if(f[i]==-1)
			{
				f[i]=x;
				return true;
			}
			else if(find(f[i]))
			{
				f[i]=x;
				return true;
			}
		}
	}
	return false;
}
int main()
{
		scanf("%d %d",&n,&m);
		memset(f,-1,sizeof(f));
		memset(fr,false,sizeof(fr));
		for(int i=1;i<=m;i++)
		{
			int x,y;
			scanf("%d %d",&x,&y);
			fr[x][y]=true;
		}
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			memset(vis,false,sizeof(vis));
			if(find(i))
			ans++;
		}
		printf("%d\n",ans);
	return 0;
	
}





猜你喜欢

转载自blog.csdn.net/crystaljy/article/details/77432183