H - A-B Game

Fat brother and Maze are playing a kind of special (hentai) game by two integers A and B. First Fat brother write an integer A on a white paper and then Maze start to change this integer. Every time Maze can select an integer x between 1 and A-1 then change A into A-(A%x). The game ends when this integer is less than or equals to B. Here is the problem, at least how many times Maze needs to perform to end this special (hentai) game.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers A and B described above.

1 <= T <=100, 2 <= B < A < 100861008610086

Output

For each case, output the case number first, and then output an integer describes the number of times Maze needs to perform. See the sample input and output for more details.

Sample Input

2
5 3
10086 110

Sample Output

Case 1: 1
Case 2: 7

AC代码(贪心只要找到取余最大的数就可以了可以是(a/2+1)也可以是分情况讨论偶数((a+2)/2)奇数((a+1)/2)

#include <iostream>
#include <stdio.h>
using namespace std;

int main()
{
   int t, k;
   long long a, b, c;
   scanf("%d",&t);
   for(k = 1;k<=t;k++)
   {
       int h = 0;
       scanf("%I64d %I64d",&a, &b);
       while(a>b)
       {
            h++;
           if(a%2==0)
         c = (a+2)/2;
     else
     c = (a+1)/2;
            a = a-(a%(c));
       }
      printf("Case %d: %d\n",k, h);
   }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41524782/article/details/81203938
A-B