H - Parity game (带权并查集)

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

题解:将所给区间通过STL中map的可去重特性转换为点与点之间的关系。

进而转换为带权并查集。

#include<iostream>
#include<map>
#include<stdio.h>
#include<cstring>
using namespace std;
const int INF=0x3f3f3f3f;
map<int,int>mp;
int f[10050],diff[10050],pos,n,m,cnt;
char s[10];
int getf(int x)
{
    if(f[x]==0)
        return x;
    int pre=f[x];
    f[x]=getf(f[x]);
    diff[x]=(diff[x]+diff[pre])%2;
    return f[x];
}
void merge_(int u,int v)
{
    int t1=getf(u);
    int t2=getf(v);
    if(t1!=t2)
        f[t2]=t1;
}
int main()
{
    cin>>n>>m;
    pos=m;
    int flag=0;
    for(int i=1;i<=m;i++)
    {
        int u,v,d;
        cin>>u>>v>>s;
        if(flag)
            continue;
        if(mp[u-1]==0)
            mp[u-1]=++cnt;
        if(mp[v]==0)
            mp[v]=++cnt;
        u=mp[u-1],v=mp[v];
        if(s[0]=='o')
            d=1;
        else
            d=0;
        int t1=getf(u);
        int t2=getf(v);
        if(t1==t2)
        {
            if((diff[u]-diff[v]+2)%2!=d)
            {
                pos=i-1;
                flag=1;
            }
        }
        else
        {
            f[t1]=t2;
            diff[t1]=(diff[v]+d-diff[u]+2)%2;
        }
    }
    cout<<pos<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43824158/article/details/87528988