hdu 3622 Bomb Game(二分+2-sat)

Bomb Game

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5985    Accepted Submission(s): 2167


Problem Description
Robbie is playing an interesting computer game. The game field is an unbounded 2-dimensional region. There are N rounds in the game. At each round, the computer will give Robbie two places, and Robbie should choose one of them to put a bomb. The explosion area of the bomb is a circle whose center is just the chosen place. Robbie can control the power of the bomb, that is, he can control the radius of each circle. A strange requirement is that there should be no common area for any two circles. The final score is the minimum radius of all the N circles.
Robbie has cracked the game, and he has known all the candidate places of each round before the game starts. Now he wants to know the maximum score he can get with the optimal strategy.
 

Input
The first line of each test case is an integer N (2 <= N <= 100), indicating the number of rounds. Then N lines follow. The i-th line contains four integers x 1i, y 1i, x 2i, y 2i, indicating that the coordinates of the two candidate places of the i-th round are (x 1i, y 1i) and (x 2i, y 2i). All the coordinates are in the range [-10000, 10000].
 

Output
Output one float number for each test case, indicating the best possible score. The result should be rounded to two decimal places.
 

Sample Input
 
  
2 1 1 1 -1 -1 -1 -1 1 2 1 1 -1 -1 1 -1 -1 1
 

Sample Output
 
  
1.41 1.00
 
思路:
二分一个半径,然后2-sat建图。
代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=205;
int X[maxn],Y[maxn],n;
vector<int>G[maxn];
stack<int>P;
int dfn[maxn],low[maxn],fa[maxn],tol,num;
int instack[maxn];
double dist(int i,int j)
{
    return sqrt((X[i]-X[j])*(X[i]-X[j])+(Y[i]-Y[j])*(Y[i]-Y[j]));
}
void tarjan(int v)
{
    dfn[v]=low[v]=++tol;
    P.push(v);instack[v]=1;
    for(int i=0;i<G[v].size();i++)
    {
        int to=G[v][i];
        if(!dfn[to])
        {
            tarjan(to);
            low[v]=min(low[v],low[to]);
        }
        else if(instack[to]) low[v]=min(low[v],dfn[to]);
    }
    if(dfn[v]==low[v])
    {
        num++;int t;
        do
        {
            t=P.top();P.pop();
            fa[t]=num;
            instack[t]=0;
        }
        while(v!=t);
    }
}
bool judge()
{
    for(int i=1;i<=n;i++)
        if(fa[i]==fa[i+n]) return 0;
    return 1;
}
bool check(double L)
{
    tol=num=0;
    for(int i=0;i<maxn;i++)
    {
        G[i].clear();
        dfn[i]=low[i]=instack[i]=0;
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            if(i==j)continue;
            if(dist(i,j)<2*L) G[i].push_back(j+n);
            if(dist(i,j+n)<2*L) G[i].push_back(j);
            if(dist(i+n,j)<2*L) G[i+n].push_back(j+n);
            if(dist(i+n,j+n)<2*L) G[i+n].push_back(j);
        }
    }
    for(int i=1;i<=2*n;i++)
        if(!dfn[i])tarjan(i);
    return judge();
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
            scanf("%d%d%d%d",&X[i],&Y[i],&X[i+n],&Y[i+n]);
        double l=0.0,r=100000.0;
        while(r-l>1e-5)
        {
            double mid=(l+r)/2;
            if(check(mid)) l=mid;
            else r=mid;
        }
        printf("%.2lf\n",r);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/albertluf/article/details/80974869