1046 Shortest Distance(20 分)

1046 Shortest Distance(20 分)
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10
​5
​​ ]), followed by N integer distances D
​1
​​ D
​2
​​ ⋯ D
​N
​​ , where D
​i
​​ is the distance between the i-th and the (i+1)-st exits, and D
​N
​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10
​4
​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10
​7
​​ .

Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

解题思路:
计算环形链上任意两点间的最短距离,也就是正着走和反着走哪个近。
用total记录环形的总距离,ans记录正着走的距离,输出其中较小的。
用dis[i]记录从第0个到i的距离,dis[ed-1]-dis[st-1]就是st到ed的正向距离。
dis数组在读入时就记录,如果在每一次查询中再去跑一边st到ed的距离,会超时。

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=100010;
int main(){
    int n,m,total=0;
    int a[maxn],dis[maxn];
    dis[0]=0;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&a[i]);
        total+=a[i];
        dis[i]=total;
    }
    scanf("%d",&m);
    for(int i=0;i<m;i++) {
        int st,ed,ans=0;
        scanf("%d%d",&st,&ed);
        if(st>ed){
            swap(st,ed);
        }
        ans=dis[ed-1]-dis[st-1];
        printf("%d\n",min(ans,total-ans));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chenyutingdaima/article/details/82080634