1046 Shortest Distance (20)(20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 10^5^]), followed by N integer distances D~1~ D~2~ … D~N~, where D~i~ is the distance between the i-th and the (i+1)-st exits, and D~N~ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=10^4^), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^7^.
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

刚开始没注意到环的大小,用邻接表做,空间复杂度太高
仔细一看环的任意两点不就两条路吗,只要算出环长和任意一条路的大小,另一条不就出来了吗
时间复杂度O(N)
提前计算前缀和即可

#include <bits/stdc++.h>
using namespace std;
int dist[100010];
int sum[100010];
int main(){
    int N;
    cin>>N;
    int total=0;
    for(int i=1;i<=N;i++){
        cin>>dist[i];
        total+=dist[i];
        sum[i]=sum[i-1]+dist[i];
    }
    int K;
    cin>>K;
    for(int i=1;i<=K;i++){
        int a,b;
        cin>>a>>b;
        if(b<a){
            swap(a,b);
        }
        int temp=sum[b-1]-sum[a-1];
        cout<<min(temp,total-temp)<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38677814/article/details/80839846