拓扑判断是否有环

/*
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0. 
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
Output
For each test case, print in one line the judgement of the messy relationship. 
If it is legal, output "YES", otherwise "NO".
Sample Input
3 2
0 1
1 2
2 2
0 1
1 0
0 0
Sample Output
YES
NO
*/ 
/*
拓扑判断是否有环 
思路   用拓扑法 找出  入度可为0的点  并进行统计;
如果它等于n 则表示没有环  否则 则有环;


坑点  本题可能会多次输入多组数据   
所以      输入时    if(!bian[x][y])
            {
                bian[x][y]=1;
                vis[y]++;
            }

*/
#include<stdio.h>
#include<string.h>
/**/
int n,m;
const int cc = 1e3+10;
int bian[cc][cc];
int vis[cc];
int t=0;
void tupo()
{
    for(int i=0;i<=n;i++)
        for(int j=0;j<n;j++)
        {
            if(vis[j]==0)
            {
                t++;
                vis[j]--;        
                for(int k=0;k<n;k++)
                {
                    if(bian[j][k])    
                    {
                        bian[j][k]--;
                        vis[k]--;
                    }
                }                            
            }
        }
}
int main()
{
    while(scanf("%d%d",&n,&m)&&(n))
    {
        int x,y;
        memset(bian,0,sizeof(bian));
        memset(vis,0,sizeof(vis));
        t = 0;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&x,&y);
            if(!bian[x][y])
            {
                bian[x][y]=1;
                vis[y]++;
            }

        }
        tupo();
        if(t==n)    printf("YES\n");
        else  printf("NO\n");
    } 
}

猜你喜欢

转载自blog.csdn.net/lijianzhong1/article/details/81415121