J - Red and Black 寒假练习1-J

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
….#.
…..#
……
……
……
……
……

@…

.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..

.

…@…

.

..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
来源:zoj2165
解题思路:
找到格点‘@’,以‘#’为基础广搜,输出找到的‘.’,格点个数。
代码:

#include<stdio.h>
#include<string.h>
char map[105][105];
int m,n,v;
int next[4][2]={1,0,0,1,-1,0,0,-1};
void bfs(int x,int y)
{
    for(int k=0;k<4;k++)
    {

        int tx=x+next[k][0];
        int ty=y+next[k][1];

        if(map[tx][ty]!='.'||tx<0||tx>=n||ty<0||ty>=m)
        continue;   
//      printf("%d %d m=%d n=%d\n",tx,ty,m,n);
        if(map[tx][ty]=='.')
        {
            v++;
            map[tx][ty]='#';
            bfs(tx,ty); 
        }
    }
}
int main()
{
    while(scanf("%d%d",&m,&n),m||n)
    {
        int i,j;
        for(i=0;i<n;i++)
        scanf("%s",map[i]);
        int f=0; 
//      for(i=0;i<n;i++)
//      {
//          for(j=0;j<m;j++)
//          {
//              printf("%c ",map[i][j]);
//          }
//          printf("\n");
//      }
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(map[i][j]=='@')
                {
                    f=1;
                    break;
                }
            }
            if(f==1)
            break;
        }
        v=1;
        map[i][j]='#';
        bfs(i,j);
        printf("%d\n",v);
    }
    return 0;
} 

错误解析:初始点走过了就不再走了,搜索时注意边界问题。

猜你喜欢

转载自blog.csdn.net/watestill/article/details/79182469