AcWing 每日一题 2022/5/1【2057. 比赛时间】

AcWing 每日一题 2022/5/1【2057. 比赛时间】

奶牛贝茜已经厌倦了牛奶生产行业,并希望转而从事令人兴奋的计算机行业。

为了提高自己的编程能力,她决定参加在线 USACO 比赛。

由于她注意到比赛开始于 2011 年 11 月 11 日(11/11/11),于是她决定下载问题并在 11/11/11 上午 11:11 开始答题。

不幸的是,贝茜的时间管理能力很差,因此她想编写一个快速程序来帮助她确保比赛时间不超过 3 小时(180 分钟)。

给定她停止答题的日期和时间,请帮助贝茜计算她在比赛中花费的总分钟数。

输入格式
共一行,包含三个整数 D,H,M。表示贝茜停止答题的日期,小时,分钟。

用 24 小时制记录时间。

输出格式
输出贝茜在比赛中花费的总分钟数。

如果结束时间比开始时间还早,则输出 −1。

数据范围

11≤D≤14,
0≤H≤23,
0≤M≤59

输入样例:

12 13 14

输出样例:

1563

题目解析

纯纯大水题,水到不能再水了

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<sstream>

#define x first
#define y second

using namespace std;
typedef long long ll;
typedef pair<int, int> PII;
const int N = 100000;
const int MOD = 1000000007;
const int INF = 0x3f3f3f3f;

int gcd(int a, int b){
    
    return b ? gcd(b, a % b) : a;}

int main()
{
    
    
	int d, h, m;
	cin >> d >> h >> m;
	int time =  (d - 11) * 24 * 60 + (h - 11) * 60 + (m - 11);
	if(time >= 0) cout << time << endl;
	else cout << -1 << endl;
	return 0;
}



猜你喜欢

转载自blog.csdn.net/qq_52354698/article/details/124532782