HDU2709||Sumsets

link:http://acm.hdu.edu.cn/showproblem.php?pid=2709

    Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

整数递推,这个题从1开始,结果依次为 1 2 2 4 4 6 6 10 10 14 14 20 20 26 26 36 36 46 46 60 60 74

可以看出当这个数是奇数x时,a[x]=a[x-1]

偶数时,a[x]=a[x-2]+a[x/2]

因为题目限制输出后九位,所以都要对1e9取余
AC代码:

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
const int N=1000100;
int mod=1000000000;
int a[N];
void fun()
{
    int i;
    a[1]=1;
    a[2]=2;
    for(i=3;i<N;i++)
    {
        if(i%2==1)
            a[i]=a[i-1]%mod;
        else
            a[i]=(a[i-2]+a[i/2])%mod;
    }
}
int main()
{
    int n;
    fun(); 
    while(~scanf("%d",&n))
    printf("%d\n",a[n]);
return 0;
} 

猜你喜欢

转载自blog.csdn.net/csdn_muxin/article/details/78147967