POJ 2229 Sumsets(规律)

这是一道意想不到的规律题。。。。。。。。。。。。或许是我比较菜,找不到把。

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

规律是:1 2 2 4 4 6 6 10 10 14 14 20 20 26 26 36,,,由这里不难可以看出,如果是奇数位,则于他前一位相当。。。重点是偶数位,d[i]=d[i-1]+d[i/2],这规律真的是。。。。
AC代码:
#define MOD 10000000000
#define MAX 20000
#include<stdio.h>
int d[MAX];
int main()
{
    int n;
    scanf("%d",&n);
    d[1]=1;
    d[2]=2;
    for(int i=3 ;i<=n ;i++)
        if(i & 1)
            d[i]=d[i-1]%MOD;
        else
            d[i]=(d[i-1]+d[i/2])%MOD;
        printf("%d\n",d[n]);
        return 0;
}
View Code

猜你喜欢

转载自www.cnblogs.com/shuaihui520/p/8975588.html