Sumsets

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

代码

#include<iostream>   
#include<string.h>   
int dp[1000003];  
using namespace std;  
int main()  
{  
    int n;
    cin>>n; 
    int q=n,t=1,i;  
    memset(dp,0,sizeof(dp));  
    dp[0]=1;  
    while(1)  
    {  
        if(!q)
            break;
        q=q/2;  
        for(i=t;i<=n;i++)  
           dp[i]=(dp[i]+dp[i-t])%1000000000;  
        t=t*2;  
    }  
    cout<<dp[n]<<endl; 
    return 0;  
}  
//状态转移
//d [ n ] = d [ n ] + d [ n - t ] ;

猜你喜欢

转载自blog.csdn.net/lshsgbb2333/article/details/79902404