POJ 2229 Sumsets(简单dp)

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

题目大意:给出一个数,要求这个数能分成2进制相加的形式的种数。

思路:有木有觉得很像阶梯问题。二进制,实质上就是分2的幂的问题。但是需要分奇偶的情况,因为奇数时仅仅比上一个偶数多一个1,而这个多余的1是无法与与其他结合形成2的幂次数,所以奇数的种数就是上一个偶数的种数。如果为偶数,那么也分两种情况,有1和没1。对于有1的情况可以直接拆出两个1,然后变为n-2的情况。对于没有1的情况可以直接将其转化为n/2,因为n拆分出所有的数字都是2的倍数,只需要将每种拆分结果中的数字都除以2就会与n/2的一种拆分相对应。

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define MOD 1000000000
using namespace std;
const int maxn=10000000;
long long a[maxn];
int main()
{
    memset(a,0,sizeof(a)); 
    int n;
    while(scanf("%d",&n)!=EOF)
    {
       a[0]=a[1]=1;
       for(int i=2;i<=n;++i) 
	   {
           if(i%2==1) 
		   {
               a[i]=a[i-1];
           }
           else
		   {
               a[i]=a[i/2]%MOD+a[i-2]%MOD;
           }
           a[i]=a[i]%MOD;
       }
       cout<<a[n]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/pleasantly1/article/details/81274361