Sumsets - poj2229 - dp

Sumsets

Time Limit: 2000MS   Memory Limit: 200000K
Total Submissions: 23193   Accepted: 8891

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Source

USACO 2005 January Silver

思路:

dp[i]:=数i的划分种数

  • 若数i是奇数则i-1是偶数,dp[i]=dp[i-1];
  • 若数i是偶数
  1. 组合中含有1 -> dp[i-1]
  2. 组合中没有1,全是偶数 ->dp[i/2]

dp[i][j]=dp[i-1]+dp[i/2];

就像4的划分(2,2和4)与2的划分(1,1和2)种数是一样的

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<queue> 
#include<vector>

using namespace std;

int n,dp[1000005];

int main(){
	scanf("%d",&n);
	dp[1]=1;
	for(int i=2;i<=n;i++){
		if(i%2){
			dp[i]=dp[i-1];
		}
		else dp[i]=(dp[i-1]+dp[i/2])%1000000000;
	}
    cout<<dp[n]<<endl;
}

加油加油加油加油加油!!!

猜你喜欢

转载自blog.csdn.net/m0_37579232/article/details/81319760