SDUT-3344-数据结构实验之二叉树五:层序遍历

Problem Description

已知一个按先序输入的字符序列,如abd,eg,cf,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。
Input
输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。
Output
输出二叉树的层次遍历序列。
Sample Input

2
abd,eg,cf,
xnl,i,u,

Sample Output

abcdefg
xnuli

Hint

Source
xam

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct tree
{
    struct tree *left,*right;
    char data;
};
int i;
char a[55];
struct tree * creat()
{
    if(a[i]==',')
    {
        i++;
        return NULL;
    }
    else
    {
        struct tree *t;
        t=(struct tree *)malloc(sizeof(struct tree));
        t->data=a[i];
        i++;
        t->left=creat();
        t->right=creat();
        return t;
    }
}
void arrangeshow(struct tree *t)
{
    struct tree *treenode[55];
    int in=0,out=0;
    treenode[in++]=t;
    while(in>out)
    {
        if(treenode[out]!=NULL)
        {
            treenode[in++]=treenode[out]->left;
            treenode[in++]=treenode[out]->right;
            printf("%c",treenode[out]->data);
        }
        out++;
    }
}
int main()
{
    int t;
    struct tree *root;
    scanf("%d",&t);
    while(t--)
    {
        i=0;
        scanf("%s",a);
        root=creat();
        arrangeshow(root);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44041997/article/details/86604121