数据结构实验之二叉树二:遍历二叉树 SDUT

数据结构实验之二叉树二:遍历二叉树

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,de,g,f, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。
Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。
Output

每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。

Sample Input

abc,de,g,f,
Sample Output

cbegdfa
cgefdba

#include<stdio.h>
#include<stdlib.h>
struct node
{
    char data;
    struct node *l, *r;
};
char a[51];
int top;
struct node *creat()
{
    struct node *root;
    top++;
    if(a[top] == ',')
        root = NULL;
    else
    {
        root = (struct node*) malloc(sizeof(struct node));
        root->data = a[top];
        root->l = creat();
        root->r = creat();
    }
    return root;
};
void zhongxu(struct node *root)
{
    if(root)
    {
        zhongxu(root -> l);
        printf("%c", root -> data);
        zhongxu(root -> r);
    }
}
void houxu(struct node *root)
{
    if(root)
    {
        houxu(root -> l);
        houxu(root -> r);
        printf("%c", root -> data);
    }
}
int main()
{
    while(~scanf("%s", a))
    {
        top = -1;
        struct node *root;
        root = creat();
        zhongxu(root);
        printf("\n");
        houxu(root);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/king9666/article/details/88202168