【 HDU - 1711 】M - Number Sequence (KMP)

题目:

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

代码:

kmp模板题

#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
int t,Next[10050],a[1000050],b[10050],m,n; 

void getNext(int b[10050]) //获取next数组
{
    
    
	fill(Next,Next+10050,0);
	int j=-1;
	Next[0]=-1;
	for(int i=1;i<m;i++)
	{
    
    
		while(j!=-1 && b[i]!=b[j+1]){
    
    
			j=Next[j];
		}
		if(b[i]==b[j+1]) j++;
		Next[i]=j;
	}
}

int kmp(int a[1000050],int b[10050])
{
    
    
	getNext(b);
	int j=-1;
	for(int i=0;i<n;i++)
	{
    
    
		while(j!=-1 && a[i]!=b[j+1]){
    
    
			j=Next[j];
		}
		if(a[i]==b[j+1]) j++;
		if(j==m-1) return i-m+2; //返回下标 i-(m-1)+1
	}
	return -1;
}

int main()
{
    
    
	scanf("%d",&t);
	while(t--)
	{
    
    
		fill(a,a+1000050,0); //初始化数组
		fill(b,b+10050,0);
		scanf("%d%d",&n,&m);
		for(int i=0;i<n;i++) scanf("%d",&a[i]);
		for(int i=0;i<m;i++) scanf("%d",&b[i]);
		cout<<kmp(a,b)<<endl;
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_45260385/article/details/108220474
今日推荐