B - 畅通工程续 HDU - 1874

某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。 

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
Input本题目包含多组数据,请处理到文件结束。 
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。 
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。 
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。Output对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1. 
Sample Input
3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2
Sample Output
2
-1
#include<stdlib.h>
#include<stdio.h>
#include<iostream>  
#include<vector>  
#include <algorithm>
#include<math.h>

using namespace std; 

int main()
{
	int n,m; //n个城市 m个道路(双向)!存在第0个城市
	while(scanf("%d%d",&n,&m)!=EOF){
		int map[210][210];
		for(int i=0;i<210;i++){
			for(int j=0;j<210;j++)map[i][j]=100000;
		    map[i][i]=0;
		}
		for(int i=0;i<m;i++){
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			if(c<map[a][b])map[a][b]=map[b][a]=c; //当两个城市之间修多条路时  选择最短的路径 !!!!
		}
		for(int p=0;p<n;p++){  //用p松弛
			for(int i=0;i<n;i++)
				for(int j=0;j<n;j++){
					if(map[i][p]+map[p][j]<map[i][j])map[i][j]=map[i][p]+map[p][j];
				}
		}
		int s,e;
		scanf("%d%d",&s,&e);
		if(map[s][e]!=100000)
		    printf("%d\n",map[s][e]);
		else printf("-1\n");
	}
}
注意重复的边取最小值!!!    wa n次的教训

猜你喜欢

转载自blog.csdn.net/leo_10/article/details/79981924