畅通工程续//HDU - 1874//floyd

畅通工程续//HDU - 1874//floyd


题目

某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
Sample Input
3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2
Sample Output
2
-1
链接:https://vjudge.net/contest/351234#problem/J

思路

最短路径,floyd就完事了

代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>

using namespace std;
int root[10000];
int n,m;
int longa[210][210];
const int INF = 1e8;

void init(){                                                //初始化floyd数组
    for(int i=0;i<n;i++){
        for(int j=0;j<n;j++){
            longa[i][j]=(i==j?0:INF);
        }
    }
    return ;
}

void floyd(){                                                 //利用floyd传递闭包算出各个城市间的最短距离
    for(int k=0;k<n;k++){
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                if(longa[i][k]==INF||longa[k][j]==INF)
                    continue;
                if(longa[i][j]==INF||longa[i][k]+longa[k][j]<longa[i][j])
                    longa[i][j]=longa[i][k]+longa[k][j];
            }
        }
    }
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF){
        init();
        for(int i=0;i<m;i++){
            int a,b,c;
            cin>>a>>b>>c;
            if(c<longa[a][b])
                longa[a][b]=longa[b][a]=c;
        }
        floyd();
        int ansa,ansb;
        cin>>ansa>>ansb;
        if(longa[ansa][ansb]==INF)
            cout<<"-1"<<endl;
        else
            cout<<longa[ansa][ansb]<<endl;;
    }
    return 0;
}

注意

输入时有输入两个相同城市之间不同距离,要判断哪个短。

发布了24 篇原创文章 · 获赞 9 · 访问量 535

猜你喜欢

转载自blog.csdn.net/salty_fishman/article/details/103967673