HDU1874畅通工程续(SPFA算法)

畅通工程续

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 68682    Accepted Submission(s): 26539


 

Problem Description

某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。

Input

本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。

Output

对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.

Sample Input

3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2

Sample Output

2
-1

Author

linle

Source

2008浙大研究生复试热身赛(2)——全真模拟

问题链接:HDU1874畅通工程续

问题分析:此问题更适合用Dijkstra算法求解,使用SPFA算法只为练习

程序说明:略

AC的C++程序:

#include<iostream>
#include<queue>
#include<vector>

using namespace std;

const int INF=0x3f3f3f3f;
const int N=205;

struct Edge{//边 
	int v,cost;//起点到终点v的花费为cost 
	Edge(int v,int cost):v(v),cost(cost){} 
};

int dist[N];//距离
bool vis[N];//标记结点是否进队列
int cnt[N];//标记结点进队列的次数 
vector<Edge>g[N];//图的邻接表表示

bool spfa(int n,int s)//n是结点的个数,s是源点 
{
	queue<int>q;
	for(int i=0;i<n;i++){
		vis[i]=false;
		cnt[i]=0;
		dist[i]=INF;
	}
	vis[s]=true;
	dist[s]=0;
	cnt[s]=1;
	q.push(s);
	while(!q.empty()){
		int u=q.front();
		q.pop();
		vis[u]=false;//出队列标记为false 
		int num=g[u].size();//以u为起点的终点个数
		for(int i=0;i<num;i++){
			int v=g[u][i].v;//终点编号 
			if(dist[u]+g[u][i].cost<dist[v]){
				dist[v]=dist[u]+g[u][i].cost;
				if(!vis[v]){
					q.push(v);
					vis[v]=true;
					cnt[v]++;
					if(cnt[v]>=n)
					  return false;
				}
			}
		} 
	}
	return true;
}

int main()
{
	int n,m,a,b,x,s,t;
	while(scanf("%d%d",&n,&m)!=EOF){
		while(m--){
			scanf("%d%d%d",&a,&b,&x);
			g[a].push_back(Edge(b,x));
			g[b].push_back(Edge(a,x));
		}
		scanf("%d%d",&s,&t);
		int flag=spfa(n,s);
		if(flag&&dist[t]!=INF)
		  printf("%d\n",dist[t]);
		else
		  printf("-1\n");
		for(int i=0;i<=n;i++)
		  g[i].clear(); 
	}
	return 0;
}

 

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/81321488