7-12 文件传输(25 分)

当两台计算机双向连通的时候,文件是可以在两台机器间传输的。给定一套计算机网络,请你判断任意两台指定的计算机之间能否传输文件?

输入格式:

首先在第一行给出网络中计算机的总数 N (2),于是我们假设这些计算机从 1 到 N 编号。随后每行输入按以下格式给出:

I c1 c2

其中I表示在计算机c1c2之间加入连线,使它们连通;或者是

C c1 c2

其中C表示查询计算机c1c2之间能否传输文件;又或者是

S

这里S表示输入终止。

输出格式:

对每个C开头的查询,如果c1c2之间可以传输文件,就在一行中输出"yes",否则输出"no"。当读到终止符时,在一行中输出"The network is connected."如果网络中所有计算机之间都能传输文件;或者输出"There are k components.",其中k是网络中连通集的个数。

输入样例 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

输出样例 1:

no
no
yes
There are 2 components.

输入样例 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

输出样例 2:

no
no
yes
yes

The network is connected.并查集问题。刚开始输出错误,问题出来最后的判断,如果只有一个集合,则证明所有的机器都连接在一起了。

    #include<stdio.h>
    #include<iostream>
    #define maxn 199999
    using namespace std;
    int f[maxn];
    int n;
    void init()
    {
        for(int i=1;i<=n;i++)
            f[i]=i;
    }
    int getf(int a)
    {
        if(f[a]==a)
            return a;
        else{
            f[a]=getf(f[a]);
            return f[a];
        }
    }
    void merg(int v,int u)
    {
        int t1=getf(v);
        int t2=getf(u);
        if(t1!=t2)
            f[t2]=t1;
    }
    bool zz(int c1,int c2)
    {
        if(getf(c1)==getf(c2))
            return 1;
        else
            return 0;
    }
    int main()
    {
        cin>>n;
        getchar();
        char c;
        int c1,c2;
        int sum=0;
        init();
        while(cin>>c){
            if(c=='S')
                break;
        cin>>c1>>c2;
            if(c=='C'){
                if(getf(c1)==getf(c2))
                    cout<<"yes"<<endl;
                else
                    cout<<"no"<<endl;
            }
            if(c=='I')
                merg(c1,c2);
        }
        for(int i=1;i<=n;i++){
            if(f[i]==i)
                sum++;
        }
        if(sum==1)
            printf("The network is connected.");
        else
            printf("There are %d components.",sum);
    }

猜你喜欢

转载自blog.csdn.net/qq_42018521/article/details/80384553
今日推荐