7-11 文件传输 (25 分)

当两台计算机双向连通的时候,文件是可以在两台机器间传输的。给定一套计算机网络,请你判断任意两台指定的计算机之间能否传输文件?

输入格式:

首先在第一行给出网络中计算机的总数 N (2≤N≤104​​ ),于是我们假设这些计算机从 1 到 N 编号。随后每行输入按以下格式给出:

I c1 c2
其中I表示在计算机c1和c2之间加入连线,使它们连通;或者是

C c1 c2
其中C表示查询计算机c1和c2之间能否传输文件;又或者是

S
这里S表示输入终止。

输出格式:

对每个C开头的查询,如果c1和c2之间可以传输文件,就在一行中输出"yes",否则输出"no"。当读到终止符时,在一行中输出"The network is connected.“如果网络中所有计算机之间都能传输文件;或者输出"There are k components.”,其中k是网络中连通集的个数。

输入样例 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

输出样例 1:

no
no
yes
There are 2 components.

输入样例 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

输出样例 2:

no
no
yes
yes
The network is connected.
并查集算法,要注意连通集数大于一是要输出连通集数量

#include<bits/stdc++.h>
using namespace std;
#define maxn 10010
int pa[maxn];
int find(int x){
	return x==pa[x]?x:pa[x]=find(pa[x]);
}
void unio(int x,int y){
	x=find(x);
	y=find(y);
	if(x==y) return;
	pa[x]=y;
}
int main()
{
	int n;
	char ch;
	cin>>n;
	getchar();
	for( int i=0; i<maxn; i++ ) pa[i]=i;
	while(scanf("%c",&ch)){
		int v1,v2;
		cin>>v1>>v2;
		if(ch=='C'){
			if(find(v1)==find(v2)) cout<<"yes\n";
			else cout<<"no\n";
		}
		else if(ch=='I') unio(v1,v2);
		else if(ch=='S'){
			int cnt=0,cnt1=0;
			for( int i=1; i<=n; i++ ) if(pa[i]==i) cnt++;
			if(cnt>1) printf("There are %d components.\n",cnt);
			else printf("The network is connected.\n");
			return 0;
		}
		getchar();
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43323172/article/details/88865011