7-12 最长对称子串 (25 分)

题目描述

对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定Is PAT&TAP symmetric?,最长对称子串为s PAT&TAP s,于是你应该输出11。

输入格式:

输入在一行中给出长度不超过1000的非空字符串。

输出格式:

在一行中输出最长对称子串的长度。

输入样例:

Is PAT&TAP symmetric?

输出样例:

11

#include<bits/stdc++.h>
using namespace std;
#define maxn 60
int fun(string &a){
	string b=a;
	reverse(a.begin(),a.end());
	if(a==b) return 1;
	else return 0;
}
int main()
{
	string a,b;
	int max=0;
	getline(cin,a);
	for( int i=0; i<a.length(); i++ ){
		int j=a.length()-1;
		while(j>i&&a[j]!=a[i]) j--;
		b=a.substr(i,j-i+1);
		if(b.size()>1){
			if(fun(b)==1&&max<b.size()) max=b.size();
		}
	}
	cout<<max;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43323172/article/details/88727488