hdu1009(贪心)


FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 77314    Accepted Submission(s): 26527


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
 
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
 
  
13.333 31.500
 

Author
CHEN, Yue
 

Source
 


题本身并不难,但是要多考虑下,如,当小鼠没有猫粮,或者有些豆子白送,或者没有交换豆子的房间,或者小鼠没猫粮但是刚好只有一间屋子,且是白送猫粮的情况,总之多多考虑

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
double m,n;
while(cin>>m>>n)
{
double a[1001][3]={0},cnt=0;
if(m==(-1)&&n==(-1))
break;
if(n==0)
{printf("%.3f\n",cnt);continue;}
int i,j,k;
double t,f=1;
for(i=1;i<=n;++i)
{
scanf("%lf%lf",&a[i][1],&a[i][2]);
}
for(i=1;i<=n;++i)
{
if(a[i][2]==0)
{cnt+=a[i][1];continue;}
else 
{k=i;
for(j=i+1;j<=n;++j)
{
if(a[j][2]==0)
continue;
else if((a[j][1]/a[j][2])>(a[k][1]/a[k][2]))
k=j;
}
if(k!=i)
{
t=a[i][1],a[i][1]=a[k][1],a[k][1]=t;
t=a[i][2],a[i][2]=a[k][2],a[k][2]=t;
}
}
}
for(i=1;i<=n;++i)
{
if(a[i][2]==0)
continue;
else
{ if(m<a[i][2])
{printf("%.3f\n",cnt+(m/a[i][2])*a[i][1]);m=0;f=0;break;}
else if(m==a[i][2])
{printf("%.3f\n",cnt+a[i][1]);m=0;f=0;break;}
else 
{
m-=a[i][2];
cnt+=a[i][1];
f=1;
}
}
}
if(f==1)
printf("%.3f\n",cnt);

}
return 0;
}


猜你喜欢

转载自blog.csdn.net/chczy1/article/details/72667760