King's Order hdu 5642

King's Order

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 822    Accepted Submission(s): 451


Problem Description
After the king's speech , everyone is encouraged. But the war is not over. The king needs to give orders from time to time. But sometimes he can not speak things well. So in his order there are some ones like this: "Let the group-p-p three come to me". As you can see letter 'p' repeats for 3 times. Poor king!

Now , it is war time , because of the spies from enemies , sometimes it is pretty hard for the general to tell which orders come from the king. But fortunately the general know how the king speaks: the king never repeats a letter for more than 3 times continually .And only this kind of order is legal. For example , the order: "Let the group-p-p-p three come to me" can never come from the king. While the order:" Let the group-p three come to me" is a legal statement.

The general wants to know how many legal orders that has the length of n

To make it simple , only lower case English Letters can appear in king's order , and please output the answer modulo 1000000007

We regard two strings are the same if and only if each charactor is the same place of these two strings are the same.
 

Input
The first line contains a number T(T10)——The number of the testcases.

For each testcase, the first line and the only line contains a positive number n(n2000).
 

Output
For each testcase, print a single number as the answer.
 

Sample Input
 
  
2 2 4
 

Sample Output
 
  
676 456950 hint: All the order that has length 2 are legal. So the answer is 26*26. For the order that has length 4. The illegal order are : "aaaa" , "bbbb"…….."zzzz" 26 orders in total. So the answer for n == 4 is 26^4-26 = 456950
 


数组中的三列数分别代表开头(末尾)是一个连续的字母,两个连续的字母和三个连续的字母的排列方法,
画个图,自己推推就发现规律了.
#include <iostream>
#include <stdio.h>
#include <memory.h>
#define mod 1000000007
#define ll long long
using namespace std;

ll data[2005][4];

void dp()
{
    memset(data,0,sizeof(data));
    data[1][1]=26;
    for(int i=1;i<=2000;i++)
    {
        for(int j=1;j<=3;j++)
        {
            if(data[i][j])
            {
                if(j!=3)
                    data[i+1][j+1]=data[i][j];
                data[i+1][1]=(data[i+1][1]+data[i][j]*25)%mod;
            }
<span style="white-space:pre">	</span>}
    }
    //for(int i=1;i<=2000;i++){for(int j=0;j<3;j++)printf("%lld   ",data[i][j]);printf("\n");}
}

int main()
{
    int T,n;
    ll ans;
    dp();
    cin>>T;
    for(int i=0;i<T;i++)
    {
        cin>>n;
        ans=0;
        for(int j=1;j<=3;j++)
            ans=(ans+data[n][j])%mod;
        cout<<ans<<endl;
    }
    return 0;
}



 
发布了13 篇原创文章 · 获赞 17 · 访问量 1498

猜你喜欢

转载自blog.csdn.net/LucifeR_Shun/article/details/52851187