HDU1325-并查集

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30927    Accepted Submission(s): 7056


 

Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

 

6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1

Sample Output

 

Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.

Source

North Central North America 1997

题意 :和hdu1272的题意差不多,就是变成了有向图,考虑的有点多

坑点:是以小于0结束代码。。。还有判断环的方式改了一下

思路:并查集就是了

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=100000+10;
int pre[maxn];
bool vis[maxn],ans;
int find(int x)
{
    if (x==pre[x])
        return x;
    return find(pre[x]);
}
void unite(int x,int y)
{
    int m,n;
    n=find(x);
    m=find(y);
//    printf("%d->%d\n",x,n);
//    printf("%d-->%d\n",y,m);
    if (n!=m&&m==y)  //第一个判断是不是环,第二个判断自己的子节点有没有爸爸,如果还没有(就是爸爸还是自己本身),就记录
        pre[m]=n;
    else ans=false;  //否则就错了
    return ; 
}
int main()
{
    int n,m,i,k,sum;
    k=1;
    while (scanf("%d%d",&n,&m)!=EOF)
        {
            if (n<0&&m<0)   //坑点
                break;
            if (n==0&&m==0)
                {
                    printf("Case %d is a tree.\n",k++);
                    continue;
                }
            
            for (i=1;i<=maxn;i++)
                {
                    pre[i]=i;
                    vis[i]=false;
                }
            unite(n,m);
            vis[n]=vis[m]=true;
            ans=true;
            while (scanf("%d%d",&n,&m)!=EOF)
                {
                    if (n==0&&m==0)
                        break;
                    unite(n,m);
                    vis[n]=vis[m]=true;
                }
    //        cout<<ans<<endl;
            if (ans==false)
                {
                    printf("Case %d is not a tree.\n",k++);
                    continue;
                }
            sum=0;
            for (i=1;i<maxn;i++)
                {
                    if (vis[i]==true&&pre[i]==i)  //判断根节点有多少个,一棵树只能有一个根节点
                        {
                            sum++;
                    //        cout<<pre[i]<<" "<<i<<endl;
                        }
                    if (sum>1)
                        break;
                }
    //        cout<<sum<<" sum"<<endl;
            if (sum>1)
                printf("Case %d is not a tree.\n",k++);
            else printf("Case %d is a tree.\n",k++);
        }
    return 0;
}
发布了46 篇原创文章 · 获赞 2 · 访问量 3220

猜你喜欢

转载自blog.csdn.net/z1164754004z/article/details/84638971