POJ1308/HDU 1325 Is It A Tree?(并查集应用)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 421 Accepted Submission(s): 157
 

Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
 



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output


            For each test case display the line ``Case k is a tree.\\\\\\\" or the line ``Case k is not a tree.\\\\\\\", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

题意:给你一些有向的有序有,问你它们是否能组成一棵树

 不难理解,我们要知道怎样才能称作一棵树:

1、入度为0的点有且只有一个,也就是根节点。2、除了根节点之外的点入度必须是1 。3、不能有多个分支。

也要注意下面几种情况:

1: 0 0 空树是一棵树
2: 1 1 0 0 不是树 不能自己指向自己
3: 1 2 1 2 0 0 不是树....
4: 1 2 2 3 4 5 不是树  森林不算是树(主要是注意自己)
5: 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 1  注意 一个节点在指向自己的父亲或祖先 都是错误的 即 9-->1 错
6: 1 2 2 1 0 0 也是错误的

还有就是不要看人家用-1,-1 结尾,你就把终止条件设置为a!=-1&&b!=-1,要仔细读题人说的是 如果都是符数即终止。同理还有每个测试数据的终止条件也要看清,我在这反正是浪费了很多的时间。

最后附上AC代码

#include<iostream>
#include<cstdio>
#include<cstring>
#define MAX 100005
using namespace std;
int f[MAX],book[MAX];
int in[MAX],out[MAX];
int n,m,sum;
int k,maxroom,count;

void init()
{
	for(int i=1;i<=MAX;i++)
	{
		f[i]=i;
		book[i]=0;
	 } 
 } 
 int getf(int x)
 {
 	if(f[x]==x) return x;
 	else
 	{
 		f[x]=getf(f[x]);
 		return f[x];
	 }
 }
 void merge(int a,int b)
 {
 	int t1,t2;
 	t1=getf(a);t2=getf(b);
 	if(t1!=t2) 
 	f[t2]=t1;
 
 }
 int main()
 {
 	int a,b,c,d,i;
 	while(scanf("%d%d",&a,&b)!=EOF)
 	{
 			sum++;
 		if(!a&&!b) {
 			printf("Case %d is a tree.\n",sum);
 			continue;
		 }
		 if(!a||!b)
		 {
		 	printf("Case %d is not a tree.\n",sum);
		 	continue;
		 }
 		if(a<0&&b<0) break;
		 init();
		 memset(in,0,sizeof(in));
		 memset(out,0,sizeof(out));
		 memset(book,0,sizeof(book)); 
		 k=0;     //K表示判断每个点的入度只能为1(除了根节点) 
		 count=0; //count记录根节点(入度==0) 
 		
		 merge(a,b);
 		in[b]++;
		out[a]++; 
 		book[a]=book[b]=1;
 		while(scanf("%d%d",&c,&d))
 		{
 			if(!c||!d) break;
 			merge(c,d);
 			in[d]++;
 			out[c]++;
 			book[c]=book[d]=1;
		 }
		
		
		
		 for(i=1;i<=MAX;i++)
		 {
		 	if(book[i]&&in[i]==0) count++;
		 	if(book[i]&&in[i]!=1) k++;
		 }
		 if(count>1||count==0) {
			printf("Case %d is not a tree.\n",sum);
		 	continue;
		 }
	     if(k>1||k==0)
	     {
			printf("Case %d is not a tree.\n",sum);
	     	continue;
		 }
			printf("Case %d is a tree.\n",sum);
	 }
 	return 0;
 }

猜你喜欢

转载自blog.csdn.net/zvenWang/article/details/81301520