HDU - 1213(并查集)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1213

题目:

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44958    Accepted Submission(s): 22501


 

Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2

5 3

1 2

扫描二维码关注公众号,回复: 2814531 查看本文章

2 3

4 5

5 1

2 5

Sample Output

2 4

AC代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int vis[1005];
int findd(int r)
{
    while(vis[r]!=r)
        r=vis[r];
    return r;
}
int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        int a,b;
        for(int i=1; i<=n; i++)
            vis[i]=i;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&a,&b);
            int ha=findd(a);
            int hb=findd(b);
            if(ha!=hb) vis[ha]=hb;
        }
        getchar();
        int sum=0;
        for(int i=1; i<=n; i++)
            if(vis[i]==i)sum++;
        printf("%d\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/WQN20172674/article/details/81778519