HDU 1213 并查集

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)                Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40063                                    Accepted Submission(s): 19997


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
 
  
25 31 22 34 55 12 5
 

Sample Output
 
  
24

#include<iostream>
using namespace std;
typedef long long ll;
const int maxn=100000;
int pre[maxn];
int t;
int find(int x) //找x的爹,并且把x的长辈的爹都改了
{
    int root=x;
    while(root!=pre[root]) //当自己的爹不是自己查找
    {
        root=pre[root];
    }
    //root就是自己祖宗了//自己的祖宗的爹是自己
    int i=x;
    int farther;
    while(pre[i]!=i)    //root祖宗的后代把自己的爹改成root
    {
        farther=pre[i];       //自己的爹先保存下来//等会把他的爹改成root
        pre[i]=root;    //自己的爹改成root
        i=farther;      //把i改成上个爹的,以便下次循环把下个爹的爹改成root
    }
    return root;
}
void jion(int a,int b) //a和b之间建立联系,b要认a当爹
{
    int ra=find(a);
    int rb=find(b);     //找到a,b的祖宗
    if(ra!=rb)             //假设祖宗不同,直接把让b的祖宗认a的祖宗为祖宗就行了,所以a,b就同祖宗了
    {
        pre[rb]=ra;
    }
}

int main()
{
    cin>>t;
    while(t--)
    {
        int n,m;
        cin>>n>>m;
        for(int i=1;i<=n;i++)
            pre[i]=i;       //初始化//自己是i//自己的爹是pre[i]//自己是自己的爹
        while(m--)
        {
            int a,b;
            cin>>a>>b;
            jion(a,b);
        }
        int ans=0;
        for(int i=1;i<=n;i++)
            if(pre[i]==i) ans++;
        cout<<ans<<endl;

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codetypeman/article/details/80025750