hdu 1325 Is It A Tree? (并查集)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1325

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

 

6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1

Sample Output

 

Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.

三个注意点:

1. 判环

2. 确定根节点的度数,防止出现森林

3. 除了根节点,所有点的入度都是1

#pragma GCC optimize(2)
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
const int maxn = 1e5 + 100;
const int inf = 0x3f3f3f3f;
typedef long long ll;
int f[maxn];
int vis[maxn];
int in[maxn];
bool circle;
int num;
int tp = 0;
int find(int x)
{
	if (x == f[x])
	{
		return x;
	}
	else
	{
		return f[x] = find(f[x]);
	}
}
void _union(int a, int b)
{
	if (a == b)
	{
		circle = true;
	}
	int x = find(a);
	int y = find(b);
	if (x != y)           //判环
	{
		f[x] = y;
		//num++;           //引出一条边
	}
	else                  //如果a和b有共同的祖先,那么a和b和其祖先形成一个环
	{
		circle = true;
	}
}
int main()
{
	//freopen("C://input.txt", "r", stdin);
	while (1)
	{
		int a, b;
		//num = 0;
		//int vim = 0;
		int tot = 0;
		circle = false;
		for (int i = 0; i <= maxn - 1; i++)
		{
			f[i] = i;
			vis[i] = false;
			in[i] = 0;        //除了根,每个节点的入度都为1
		}
		scanf("%d%d", &a, &b);
		if (a == 0 && b == 0)
		{
			printf("Case %d is a tree.\n", ++tp);
			continue;
		}
		if (a <0 && b <0)
		{
			break;
		}
		vis[a] = true;
		vis[b] = true;
		_union(a, b);
		in[b]++;
		while (1)
		{
			scanf("%d%d", &a, &b);
			if (a == 0 && b == 0)
			{
				break;
			}
			vis[a] = true;
			vis[b] = true;
			_union(a, b);
			in[b]++;
		}
		/*for (int i = 0; i <= maxn-1; i++)
		{
		if (vis[i])
		{
		vim++;          //点数
		}
		}*/
		for (int i = 0; i <= maxn; i++)
		{
			if (vis[i] && f[i] == i)
			{
				tot++;                          //确定根节点的度数,防止森林
			}
			if (in[i] > 1)
			{
				circle = true;             //判环
			}
		}
		if (!circle&&tot == 1)
		{
			printf("Case %d is a tree.\n", ++tp);
		}
		else
		{
			printf("Case %d is not a tree.\n", ++tp);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Evildoer_llc/article/details/82950460