HDU--1496--哈希-折半枚举

Consider equations having the following form:

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

Input

The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.

Output

For each test case, output a single line containing the number of the solutions.

Sample Input

1 2 3 -4
1 1 1 1
Sample Output

39088
0

思路:1.在a,b,c,d,四者同号是没有ans;

2.在哈希数组中判断,开辟空间为2*1000000+10即可;折半枚举,依次查找;

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
const int MAX=1000000;
int Hash[2000011];
int main(){
	int a,b,c,d;
	while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF){
		if(a*b>0&&b*c>0&&c*d>0){	
			printf("0\n");
		}else{ 
			memset(Hash,0,sizeof(Hash));
			int ans=0;
			for(int i=1;i<=100;i++)
				for(int j=1;j<=100;j++){ 
					Hash[MAX+a*i*i+b*j*j]++;
				} 
			for(int i=1;i<=100;i++)
				for(int j=1;j<=100;j++){
					ans+=Hash[MAX-(c*i*i+d*j*j)];
				}
			printf("%lld\n",ans*16);
		} 
	} 
}
发布了150 篇原创文章 · 获赞 73 · 访问量 6588

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/104223286