HDU1496 Equations【哈希表】

Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9370    Accepted Submission(s): 3895


Problem Description
Consider equations having the following form:  

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output
For each test case, output a single line containing the number of the solutions.
 

Sample Input
 
  
1 2 3 -4 1 1 1 1
 

Sample Output
 
  
39088 0
 

Author
LL
 

Source

问题链接HDU1496 Equations

问题简述:(略)

问题分析

  做两个哈希表来降低组合数。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:
/* HDU1496 Equations */

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 100;
const int N2 = N * N * N;
int sum1[N2 + 1], sum2[N2 + 1];

int main()
{
    int a, b, c, d;
    while(~scanf("%d%d%d%d", &a, &b, &c, &d)) {
        if((a > 0 && b > 0 && c > 0 && d > 0) || (a < 0 && b < 0 && c < 0 && d < 0)) {
            printf("0\n");
            continue;
        }

        memset(sum1, 0, sizeof(sum1));
        memset(sum2, 0, sizeof(sum2));

        int sum = 0;
        for(int i = 1; i <= N; i++)
            for(int j = 1; j <= N; j++) {
                int k = a * i * i + b * j * j;
                if(k >= 0)
                    sum1[k]++;
                else
                    sum2[-k]++;
            }
        for(int i = 1; i <= N; i++)
            for(int j = 1; j <= N; j++) {
                int k = c * i * i + d * j * j;
                if(k > 0)
                    sum += sum2[k];
                else
                    sum += sum1[-k];
            }

        // 每个解有正有负,所以结果有2^4种
        printf("%d\n", 16 * sum);
    }

    return 0;
}




猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80577386