HDU1496 Equations(hash)

HDU1496-Equations

Problem Description

Consider equations having the following form:

ax1^2+bx2^2+cx3^2+dx4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

Input

The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.

Output

For each test case, output a single line containing the number of the solutions.

Sample Input

1 2 3 -4
1 1 1 1

Sample Output

39088
0

# 题解

题意

a、b、c、d是[-50,50]的整数。x1、x2、x3、x4是[-100,100]的整数。问满足a*x1^2+b*x2^2+c*x3^2+d*x4^2=0的整式有多少个

思路

竟然可以用hash来处理这道题目。

  • 将方程式写成a * x1 * x1 + b * x2 * x2 = - (c * x3 * x3 + d * x4 * x4)的形式;
  • 50 * 100 100 + 50 100 *100=1000000,所以hash数组至少要2000000;
  • a * x1 * x1 + b * x2 * x2最小为-1000000,所以数组要加上1000000的偏移量,以保证数组下标最小为0,而不是负数;
  • 因为正负号不同不影响平方的效果,所以只枚举正数,最后乘以2的4次方(16),表示正负不同的组合。
  • 注意,当全为正数时,不存在解,可以进行一步的剪枝。

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
const double PI = acos(-1.0);
const double eps = 1e-6;
const int INF = 0x3f3f3f3f;
int T;

const int MAXN = 1e6+10;
int hash1[2*MAXN+1];

void init(){
    memset(hash1,0,sizeof(hash1));
}

int main() {
    int a,b,c,d,ans;
    while(~scanf("%d %d %d %d",&a,&b,&c,&d)){
        if((a>0 &&  b>0 && c>0 && d>0) || (a<0 &&  b <0 && c<0 && d <0)){
            printf("0\n");
            continue;
        }
        ans = 0;
        init();
        for(int x1=1;x1<=100;x1++){
            for(int x2=1;x2<=100;x2++){
                hash1[MAXN+a*x1*x1+b*x2*x2]++;
            }
        }
        for(int x3=1;x3<=100;x3++){
            for(int x4=1;x4<=100;x4++){
                ans+=hash1[MAXN-c*x3*x3-d*x4*x4];
            }
        }
        ans*=16;
        printf("%d\n", ans);
    }
    
}

猜你喜欢

转载自www.cnblogs.com/caomingpei/p/9669536.html