B - The 3n + 1 problem

B - The 3n + 1 problem
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.
Consider the following algorithm:

	1. 		 input n

	2. 		 print n

	3. 		 if n = 1 then STOP

	4. 		 		 if n is odd then   n <-- 3n+1

	5. 		 		 else   n <-- n/2

	6. 		 GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.
Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).
Sample Input
1 10
100 200
201 210
900 1000
Sample Output
1 10 20
100 200 125
201 210 89
900 1000 174
####本题思路:
需要注意的是内存限制过小,尽量不用数组。
####代码实现:

/*
最初的错误代码: 
#include<iostream>
#include<cstdio>

using namespace std ;

int odd( int x )  //把奇数偶数与质数合数弄混 
{
	int i ;
	bool flag = false ;
	if ( x % 2 == 0 )
	flag = true ; 
	return flag ;
}

int main ()
{
	int a , b ;
	while ( scanf("%d %d",&a,&b) != EOF)
	{
		int q[b-a+1] , k = 0 ;
		for ( int i = a ; i <= b ; i++ )
		{
			int c = 1 ;
			int u = i ;   //用u替换i 
			if ( i == 1 )  //又忘记写==了 
			{
				q[k] = 1 ; k++ ; continue ;
			 } 
			while ( u != 1 ) 
			{
			if ( !(odd(u)) ) {
			 u = u*3+1 ; c++ ; }
			else {
			u = u / 2 ; c++ ; }   
			}
			
			q[k] = c ; k++ ;
		}
		for ( int j = 0 ; j < k-1 ; j++ )
		{
			for ( int l = 0 ; l < k - 1 - j ; l++ )
			{
				if ( q[l] > q[l+1] )
				{
					int t = q[l] ; q[l] = q[l+1] ; q[l+1] = t ;
				}
			}
		}
	cout << q[k-1] ;
	cout << endl ; 
	}
	return 0 ;
}
*/
//正确代码 
#include<iostream>
#include<cstdio>

using namespace std ;

int main ()
{
	int a , b , max = 1 , q = 0 ;
	while ( scanf("%d %d",&a,&b) != EOF)
	{
		q++ ;
		if ( q >= 10000 ) break ; //读题不仔细  
		int max1 , min ;
		if ( b < a ) { max1 = a ; min = b ;
		}
		else if (b >= a ) { max1 = b , min = a ; //多考虑一种情况  等于的情况 
		}
		for ( int i = min ; i <= max1 ; i++ )
		{
			int c = 1 ;
			int u = i ;  
			if ( i == 1 )  
			continue ;
			while ( u != 1 ) 
			{
			if ( u%2!=0 ) {
			 u = u*3+1 ; c++ ; }
			else {
			u = u / 2 ; c++ ; }   
			}
			
			if ( c > max ) max = c ;//容易弄混 n和n个数的范围 
		}
	cout << a << ' ' << b << ' ' << max ;
	cout << endl ; 
	max = 1 ;
	}
	return 0 ;
}

####总结:
1:最开始的思路习惯性想到数组 但因为内存限制为10000k 所以使用数组会超出内存 改用“输入一个输出一个的方法”
2:最开始找数组最大值习惯性用冒泡排序后输出最后一位 经过纠错发现用“打擂法”去找最大值更方便简洁
3:总是抱有“赌徒心理”去读题,想着跳句落句,但最后因为一句话没理解明白忽视了一处特殊情况
4:最开始没有考虑b比a大的情况,导致wrong answer。
低级错误:
1:弄混了奇数偶数和质数合数的判定方法
2:总是把=错用成==

发布了27 篇原创文章 · 获赞 16 · 访问量 1986

猜你喜欢

转载自blog.csdn.net/weixin_43899069/article/details/98116144
今日推荐