The 3n + 1 problem(问题 1095)

原题链接:http://www.dotcpp.com/oj/problem1095.html

题目描述

Consider the following algorithm to generate a sequence of numbers. Start with an integer n. If n is even, divide by 2. If n is odd, multiply by 3 and add 1. Repeat this process with the new value of n, terminating when n = 1. For example, the following sequence of numbers will be generated for n = 22: 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 It is conjectured (but not yet proven) that this algorithm will terminate at n = 1 for every integer n. Still, the conjecture holds for all integers up to at least 1, 000, 000. For an input n, the cycle-length of n is the number of numbers generated up to and including the 1. In the example above, the cycle length of 22 is 16. Given any two numbers i and j, you are to determine the maximum cycle length over all numbers between i and j, including both endpoints.

输入

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

输出

For each pair of input integers i and j, output i, j in the same order in which they appeared in the input and then the maximum cycle length for integers between and including i and j. These three numbers should be separated by one space, with all three numbers on one line and with one line of output for each line of input.

样例输入

1 10
100 200
201 210
900 1000

样例输出

1 10 20
100 200 125
201 210 89
900 1000 174

解题思路

这道题求的是某个范围内的最大循环长度,何为最大循环长度,也就是

  • 对于一个数n,是偶数就除以2
  • 不是就乘以3再加1
  • 再判断n是否为1
  • 不为1继续执行第一步
  • 循环长度就是这个循环执行了多少次(包括了 n= 1的时候)

所以直接定义函数用来求循环长度,再在i到j的区间判断一下最大循环长度。
在这里我一直有个bug,就是没有比较i与j,导致系统一直判我超时,注意一下就好了

参考代码

#include<iostream>
int caculation(int n);
using namespace std;
int main()
{
	int i, j;
	int max = 0, t;
	while (cin >> i >> j)
	{
		cout << i << " " << j << " ";
		if (i > j) 
		{
			int temp;
			temp = i;
			i = j;
			j = temp;
		
		}
		for (int k = i; k != j + 1; ++k)
		{
			t = caculation(k);
			if (t > max)
			{
				max = t;
			}
		}
		cout << max << endl;
		max = 0;
	}
	return 0;
}
//用来计算循环长度
int caculation(int n)
{
	int i = 0;
	do
	{
		if (n % 2)
		{
			n = n * 3 + 1;
		}
		else
		{
			n /= 2;
		}

		++i;
	} while (n != 1);
	i = i + 1;  //当n为1也算一次
	return i;
}
发布了30 篇原创文章 · 获赞 6 · 访问量 7971

猜你喜欢

转载自blog.csdn.net/weixin_42792088/article/details/86682934
今日推荐