The 3n + 1 problem(水题,坑题)

The 3n + 1 problem

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm:
    1.      input n

    2.      print n

    3.      if n = 1 then STOP

    4.           if n is odd then n <- 3n + 1

    5.           else n <- n / 2

    6.      GOTO 2


Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 

Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

You can assume that no opperation overflows a 32-bit integer.
 

Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).
 

Sample Input
 
  
1 10 100 200 201 210 900 1000
 

Sample Output
 
  
1 10 20 100 200 125 201 210 89 900 1000 174


一道水题,也是一道坑题。本来很简单,但是没考虑到i和j的大小不确定,所以得先判断大小,然后进行遍历。

还有一个需要注意的地方是输出,输出的说明:输入原来的i和j,还有当前最长序列数,三者用一个空格隔开。

第一次没注意到的两个地方:

#include<stdio.h>
int main()
{
	long long a,b;
	while(scanf("%lld%lld",&a,&b)!=EOF)
	{
		long long i,k,t,max=0,temp;
		if(a>b) {
			temp=a;a=b;b=temp;
		}
		for(i=a;i<=b;i++)
		{
			k=1;
			t=i;
			printf("%d ",t);
			while(t>1){
				if(t%2!=0)
					t=3*t+1;
		        else
		        	t=t/2;
		        k++;
			}
			printf("%d\n",k);
			if(max<=k)
			  max=k;
		}
		printf("%lld %lld %lld \n",a,b,max);
	}
	return 0;
}

ac代码

#include<stdio.h>
int main()
{
	long long a,b,max,min;
	while(scanf("%lld%lld",&a,&b)!=EOF)
	{
		long long i,k,t,max0=0,temp;
		if(a>b) {
			max=a;min=b;
		}
		else {
			max=b;min=a;
		}
		for(i=min;i<=max;i++)
		{
			k=1;
			t=i;
			while(t>1){
				if(t%2!=0)
					t=3*t+1;
		        else
		        	t=t/2;
		        k++;
			}
			if(max0<=k)
			  max0=k;
		}
		printf("%lld %lld %lld\n",a,b,max0);
	}
	return 0;
}
对于每一个初学者来说还是得多练习。

猜你喜欢

转载自blog.csdn.net/qq_41818544/article/details/80627359