YTU OJ 1098: The 3n + 1 problem

题目描述

Consider the following algorithm to generate a sequence of numbers. Start with an integer n. If n is even, divide by 2. If n is odd, multiply by 3 and add 1. Repeat this process with the new value of n, terminating when n = 1. For example, the following sequence of numbers will be generated for n = 22: 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 It is conjectured (but not yet proven) that this algorithm will terminate at n = 1 for every integer n. Still, the conjecture holds for all integers up to at least 1, 000, 000. For an input n, the cycle-length of n is the number of numbers generated up to and including the 1. In the example above, the cycle length of 22 is 16. Given any two numbers i and j, you are to determine the maximum cycle length over all numbers between i and j, including both endpoints.

输入

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

输出

For each pair of input integers i and j, output i, j in the same order in which they appeared in the input and then the maximum cycle length for integers between and including i and j. These three numbers should be separated by one space, with all three numbers on one line and with one line of output for each line of input.

样例输入

1 10
100 200
201 210
900 1000

样例输出

1 10 20
100 200 125
201 210 89
900 1000 174

提示

杭电1032

来源

freeproblemset

【题目翻译】:

描述
考虑下面的算法来生成一个数字序列。以整数n开始,如果n是偶数,除以2。如果n是奇数,乘以3,加1。用n的新值重复此过程,当n=1时终止。例如,对于N=22:22 11、34、17、52、26、13、40、20、10、5、16 、8、4、2、 1,将生成下列序列数。猜想(但尚未证明)该算法将终止于n=α,对于每一个整数n。对于输入n,n的周期长度是生成并包括1的数字的数目。在上面的例子中,22的周期长度是16。给定两个数字i和j,你要确定在i和j之间的所有数字上的最大周期长度,包括两个端点。
输入
输入将由一系列整数i和j组成,每行一对整数。所有整数都小于1000000,大于0。
输出
对于每一对输入整数i和j,输出i,j以它们出现在输入中的相同顺序,然后是i和j之间整数的最大周期长度,这三个数字应该由一个空间分隔,所有三个数字在一行上,并且具有一行。用于输入的每一行。

注意:在输入时前面的数有可能小于后面的数,最后输出格式也要和题目中给出数据的先后顺序一致。

【代码】:

import java.util.Arrays;
import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc = new Scanner(System.in);
		while (sc.hasNext()) {
			int a = sc.nextInt();
			int b = sc.nextInt();
			int s[] = new int[Math.abs(b - a) + 1];
			int x;
			int m = a, n = b;
			if (a > b) {
				x = a;
				a = b;
				b = x;
			}
			for (int i = a; i <= b; i++) {
				int k = i;
				int sum = 1;
				while (k != 1) {
					if (k % 2 == 0)
						k /= 2;
					else
						k = k * 3 + 1;
					sum++;
				}
				s[i - a] = sum;
			}
			Arrays.sort(s);
			if (m < n)
				System.out.println(a + " " + b + " " + s[b - a]);
			else
				System.out.println(b + " " + a + " " + s[b - a]);
		}
	}
}

猜你喜欢

转载自blog.csdn.net/mcp3128/article/details/81203513
今日推荐