PAT-2019年冬季考试-甲级-7-2 Block Reversing (25分) 跟1133类似的题目

题目

Given a singly linked list L. Let us consider every K nodes as a block (if there are less than K nodes at the end of the list, the rest of the nodes are still considered as a block). Your job is to reverse all the blocks in L. For example, given L as 1→2→3→4→5→6→7→8 and K as 3, your output must be 7→8→4→5→6→1→2→3.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10e5​​) which is the total number of nodes, and a positive K (≤N) which is the size of a block. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 8 3
71120 7 88666
00000 4 99999
00100 1 12309
68237 6 71120
33218 3 00000
99999 5 68237
88666 8 -1
12309 2 33218

Sample Output:
71120 7 88666
88666 8 00000
00000 4 99999
99999 5 68237
68237 6 00100
00100 1 12309
12309 2 33218
33218 3 -1

方法

这道题跟题目1133采用了部分相同的手法,就是先把节点读进a,再按照链表顺序读进v,最后再生成目标链表的顺序ans。

特别之处

从v到ans的赋值有不同的处理手法。这部分有时间可以思考一题多解:

https://blog.csdn.net/lm18600967236/article/details/103441535

代码 

#include<iostream>
#include<vector>
struct node{
    int id,data,next;
}a[1000005];
int main(){
    int begin,n,k,s,d,e;
    cin>>begin>>n>>k;
    vector<node> v,ans;
    for(int i=0;i<n;i++){
        scanf("%d %d %d\n",&s,&d,&e);
        a[s]={s,d,e};
    }
    for(;begin!=-1;begin=a[begin].next){
        v.push_back(a[begin]);
    }
    int len=v.size(),j=0;
    int m;
    int remain=len%k;
    ans.resize(len);
    for(int i=0;i<len;i++){
        if(i<len-remain){
            m=len/k-i/k-1;
            ans[k*m+j+remain]=v[i];
            j=(j+1)%k;
        }else{
            ans[i%k]=v[i];
        }
    }
    for(int i=0;i<len;i++){
        if(i!=len-1){
            printf("%05d %d %05d\n",ans[i].id,ans[i].data,ans[i+1].id);
        }else{
            printf("%05d %d -1",ans[i].id,ans[i].data);
        }
    }
    return 0;
}
发布了21 篇原创文章 · 获赞 1 · 访问量 1181

猜你喜欢

转载自blog.csdn.net/allisonshing/article/details/104116640
今日推荐