PAT 甲级 2019年春季三月分 7-2 Anniversary (25 分)

Zhejiang University is about to celebrate her 122th anniversary in 2019. To prepare for the celebration, the alumni association (校友会) has gathered the ID’s of all her alumni. Now your job is to write a program to count the number of alumni among all the people who come to the celebration.

Input Specification:

Each input file contains one test case. For each case, the first part is about the information of all the alumni. Given in the first line is a positive integer N (≤105). Then N lines follow, each contains an ID number of an alumnus. An ID number is a string of 18 digits or the letter X. It is guaranteed that all the ID’s are distinct.

The next part gives the information of all the people who come to the celebration. Again given in the first line is a positive integer M (≤105). Then M lines follow, each contains an ID number of a guest. It is guaranteed that all the ID’s are distinct.

Output Specification:

First print in a line the number of alumni among all the people who come to the celebration. Then in the second line, print the ID of the oldest alumnus – notice that the 7th - 14th digits of the ID gives one’s birth date. If no alumnus comes, output the ID of the oldest guest instead. It is guaranteed that such an alumnus or guest is unique.

Sample Input:

5
372928196906118710
610481197806202213
440684198612150417
13072819571002001X
150702193604190912
6
530125197901260019
150702193604190912
220221196701020034
610481197806202213
440684198612150417
370205198709275042

Sample Output:

3
150702193604190912
使用map,存储校友会的校友信息,然后所有出席的人来判断一下哈。
不需要排序啊,只需要记住年龄最大的就行了。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>
#include <vector>
using namespace std;
int N,M;
map<string,bool> m;
vector<string> v;
bool cmp(string a,string b) //a的年龄大于b的年龄
{
    return a.substr(6,8) < b.substr(6,8);
}
int main()
{
    cin>>N;
    string name;
    string oldA="000000999999990000"; //所有人
    string oldB="X00000999999990000"; //校友会的人
    for(int i=0;i<N;i++)
    {
        cin>>name;
        m[name]=true;
    }
    cin>>M;
    for(int i=0;i<M;i++)
    {
        cin>>name;
        if( cmp(name,oldA) )
             oldA=name;
        if(m[name]==true)
        {
            v.push_back(name);
            if(cmp(name,oldB))
                oldB=name;
        }
    }
    printf("%d\n",v.size());
    if(oldB[0]=='X') //校友会没有人来
        cout<<oldA<<endl;
    else
        cout<<oldB<<endl;
    return 0;
}

发布了174 篇原创文章 · 获赞 18 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_41173604/article/details/100608801
今日推荐